const regex = /[^\w\s|https?:\/\/.\-*\s]|\W*\b\d+(?:\.\d+)?\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\w\\s|https?:\\\/\\\/.\\-*\\s]|\\W*\\b\\d+(?:\\.\\d+)?\\b', 'g')
const str = `Good Day,I would like to \$1000 (for example remove these parenthesis) \$test \$ asdf [and remove these brackets] inquire the price of the 3D product name here. Currently we have the other product name here which I believe has an accuracy of about 0.0005 199 200. http://www.example.com this is a test`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);