$re = '/([\"\'])(?:\\\\\1|\1\1|(?!\1).)*\1/';
$str = '\'value1\',"value2 with \\\' escaped quote\',\'value with \'\' is here\',\'value4\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);