import re
regex = re.compile(r"^()", flags=re.MULTILINE)
test_str = ("недревесное сырье:,Актинидия (15) 0,7 м,1,5 кг/га\n"
"недревесное сырье:,Калина (10) 1,2 м,0,1 кг/га\n"
"недревесное сырье:,Актинидия (15) 0,7 м,3,5 кг/га,Лимонник (15) 3,5 м,3,5 кг/га,\n"
"недревесное сырье:,Лимонник (10) 2,0 м,1,0 кг/га\n"
"недревесное сырье:,ЭЛЕУТЕРОКОКК (5) 2,0 м,0,5 кг/га\n"
"недревесное сырье:,Лимонник (10) 2,0 м,0,2 кг/га,Виноград (10) 2,0 м,0,1 кг/га\n"
"недревесное сырье:кедровый орех,аралия (5) 2,4 м,1,8 кг/га\n"
"недревесное сырье:орехи,Лещина (10) 5,0 м,20,0 кг/га\n"
"недревесное сырье:,Актинидия (10) 0,4 м,3,5 кг/га,Виноград (15) 0,3 м,0,2 кг/га\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")