package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)I\s+(?:\w+\s+){0,5}(TV|chocolate|fire)`)
var str = `I wish a TV
I want a b c d e f some chocolate
I need fire`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}