const regex = new RegExp('(^|[^\\d:])([0-5]?[0-9]:[0-5][0-9])([^\\d:]|$)', 'gm')
const str = `23:45 Description blah 00:45 hey there 34:23 and then 1:00:45 0:00
and ignore 434:40:52
79:32
54:99
4:56`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}