re = /^(\d{2}\.\d{2})(?:.*dollars.*)/m
str = '78.00600.00 dollars test'
subst = '$1 dollars'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result