re = /^(([0]?[1-9][0-9]*)|[0])(,(([0]?[1-9][0-9]*)|[0]))*$/
str = '10,3,5,0,102,025'
# Print the match result
str.match(re) do |match|
puts match.to_s
end