// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^#(?:[A-Fa-f0-9]{3}){1,2}$").unwrap();
let string = "#0F0F0F
#123
#1234
#ABC456
#1234567";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}