using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(\b|[¡¿])(?<uno>[^\s]+\s[^,]+),\s(\k<uno>)([?!]|\b)";
string substitution = @"$1$2$4";
string input = @"- Dios mÃo, ¡está aquÃ, está aquÃ!
- ¿Qué paso, qué paso?
- Me rehúso, me rehúso.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}