const regex = /(?i)(\b|[¡¿])(?<uno>[^\s]+\s[^,]+),\s(\k<uno>)([?!]|\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(\\b|[¡¿])(?<uno>[^\\s]+\\s[^,]+),\\s(\\k<uno>)([?!]|\\b)', 'gm')
const str = `- Dios mÃo, ¡está aquÃ, está aquÃ!
- ¿Qué paso, qué paso?
- Me rehúso, me rehúso.`;
const subst = `$1$2$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);