# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w)(nin)\b/$1NG/g;t' <<< "yilanin
suyunin
kalinin
batinin
kinindan
sininteki
nin
ninkisi
xxxnin
xxxninxxx
nin"