package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w)(nin)\b`)
var str = `yilanin
suyunin
kalinin
batinin
kinindan
sininteki
nin
ninkisi
xxxnin
xxxninxxx
nin`
var substitution = "$1NG"
fmt.Println(re.ReplaceAllString(str, substitution))
}