# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\w)(nin)\b"
test_str = ("yilanin\n"
"suyunin\n"
"kalinin\n"
"batinin\n"
"kinindan\n"
"sininteki\n"
"nin\n"
"ninkisi\n"
"xxxnin\n"
"xxxninxxx\n"
"nin")
subst = "$1NG"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.