using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[\t\s]*)(forgot: ""to"",)(?!\n[\t\s]*insert: ""something"",)";
string substitution = @"\1\2\n\1insert: ""something"",";
string input = @" oops: {
forgot: ""to"",
in: ""here""
},";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}