const regex = new RegExp('(^[\\t\\s]*)(forgot: "to",)(?!\\n[\\t\\s]*insert: "something",)', 'm')
const str = ` oops: {
forgot: "to",
in: "here"
},`;
const subst = `\1\2\n\1insert: "something",`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);