package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\p{Arabic}\s\p{N}]+$`)
var str = `تجريب 123 تجريب 123
123 abc 456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}