# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(dv|dovi|dolby[ .]?vision|hdr(10(P(lus)?)?)?)\b"
test_str = ("# MATCH\n"
"Series S01 1080p NF WEB-DL DDP 5.1 DoVi HDR HEVC-RlsGrp\n"
"Series S01 1080p NF WEB-DL DDP 5.1 HDR DoVi HEVC-RlsGrp\n"
"Series.S01.DV.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp\n"
"Series.S01.DoVi.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp\n"
"Series.S01.Dolby.Vision.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp\n"
"Series.S01.Dolby Vision.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp\n"
"Series.S01.HDR.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp\n"
"Series.S01.HDR10.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp\n"
"Series.S01.HDR10+.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp\n"
"Series.S01.HDR10Plus.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp\n"
"Series S01E03 2160p AMZN WEB-DL DDPA5 1 HDR10P HEVC-RlsGrp\n\n"
"# DON'T MATCH\n"
"Series.S03.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp\n"
"adventure\n"
"hdruin\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.