import Foundation
let pattern = #"\b(dv|dovi|dolby[ .]?vision|hdr(10(P(lus)?)?)?)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
# MATCH
Series S01 1080p NF WEB-DL DDP 5.1 DoVi HDR HEVC-RlsGrp
Series S01 1080p NF WEB-DL DDP 5.1 HDR DoVi HEVC-RlsGrp
Series.S01.DV.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp
Series.S01.DoVi.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp
Series.S01.Dolby.Vision.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp
Series.S01.Dolby Vision.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp
Series.S01.HDR.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp
Series.S01.HDR10.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp
Series.S01.HDR10+.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp
Series.S01.HDR10Plus.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp
Series S01E03 2160p AMZN WEB-DL DDPA5 1 HDR10P HEVC-RlsGrp
# DON'T MATCH
Series.S03.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp
adventure
hdruin
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)