import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^http:\\/\\/www.+[a-zA-Z0-9]\\.[a-z]{2,3}$";
final String string = "http://www.google.com\n"
+ "http://www.google.be\n"
+ "http://www.google.drvff\n"
+ "http://www.com\n"
+ "http://www.com.dd";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}