use strict;
my $str = 'This is ( a sample ) [ string ] to play with
This is ( a sample ) [ string] to play with';
my $regex = qr/(?<=[([]) +| +(?=[)\]])/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";