#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\b[^\s]+\b)"
Local $sString = "38/46 MAG/+2Z"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)