const regex = new RegExp('(\\b[^\\s]+\\b)', '')
const str = `38/46 MAG/+2Z`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);