using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\b[a-z]{1,}\b).*?)(\b\2\b)(.*)$";
string substitution = @"\1and\4";
string input = @"Green shirt green hat
Green shirt greenish hat
You are an artistically gifted musically gifted individual";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}