const regex = new RegExp('((\\b[a-z]{1,}\\b).*?)(\\b\\2\\b)(.*)$', 'gmi')
const str = `Green shirt green hat
Green shirt greenish hat
You are an artistically gifted musically gifted individual`;
const subst = `\1and\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);