// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^07").unwrap();
let string = "07720772093";
let substitution = "+447";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}