use strict;
my $str = 'interface TenGigE0/0/0/8
bundle id 221 mode active
lacp period short
lacp period short receive 100
lacp period short transmit 100
carrier-delay up 100 down 100
interface TenGigE0/0/0/7
shutdown
!
interface TenGigE0/0/0/8
bundle id 221 mode active
lacp period short
lacp period short receive 100
lacp period short transmit 100
carrier-delay up 100 down 100
load-interval 30
frequency synchronization
!
transceiver permit pid all
!
interface TenGigE0/0/0/9
mtu 9216
frequency synchronization
!
transceiver permit pid all
!
interface TenGigE0/0/0/10
bundle id 237 mode active
lacp period short
lacp period short receive 100
lacp period short transmit 100
carrier-delay up 120000 down 150
load-interval 30
frequency synchronization';
my $regex = qr/^([^\n]*TenGigE[^\n]*\n)[^T\n]*(?:T(?!enGigE)[^T\n]*|\n(?! carrier-delay)[^T\n]*)*(\n carrier-delay[^\n]*)/smp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}