// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)<img.+src=[\'"](?P<src>.+?)[\'"].*>"#).unwrap();
let string = "<img style=\"max-width:100%\" src=\"http://media.doisongphapluat.com/thumb_x670x/2015/12/26/thumon.png\" alt=\"\">";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}