$re = '/^[A-Z\d]{6}(?:(, ?| )(?:[A-Z\d]{6}\1)*[A-Z\d]{6} *)?$/m';
$str = 'KEPM39, JEMGH5, HEPM21
KEPM39 JEMGH5 HEPM21
KEPM39,JEMGH5,HEPM21
JEPM34, KEPM11
JEPM34, KEPM11
JEPM34
KEPM39, JEMGH5 HEPM21, HEGD44 ZZZZZZ
KEPM39, JEMGH5 HEPM21';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);