import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?'region'\\{region \"workcellX\"\\}.*?(?'IafId'(?<=\\{attribute 'IafId' := ').*?(?='\\})).*?\\{endregion\\})";
final String string = " {region \"workcellX\"}\n"
+ " ,workcellX\n"
+ " {attribute 'IafId' := '1745cf20-b0f5-45c7-903f-ee6679d073a9'}\n"
+ " {endregion}\n"
+ " {region \"workcellX\"\n"
+ " ,workcellX\n"
+ " {attribute 'IafId' := '1745cf20-b0f5-45c7-903f-ee6679d073a9'}\n"
+ " {endregion}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}