re = /(?'region'{region "workcellX"}.*?(?'IafId'(?<={attribute 'IafId' := ').*?(?='})).*?{endregion})/m
str = ' {region "workcellX"}
,workcellX
{attribute \'IafId\' := \'1745cf20-b0f5-45c7-903f-ee6679d073a9\'}
{endregion}
{region "workcellX"
,workcellX
{attribute \'IafId\' := \'1745cf20-b0f5-45c7-903f-ee6679d073a9\'}
{endregion}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end