import Foundation
let pattern = #"(?'region'{region "workcellX"}.*?(?'IafId'(?<={attribute 'IafId' := ').*?(?='})).*?{endregion})"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
{region "workcellX"}
,workcellX
{attribute 'IafId' := '1745cf20-b0f5-45c7-903f-ee6679d073a9'}
{endregion}
{region "workcellX"
,workcellX
{attribute 'IafId' := '1745cf20-b0f5-45c7-903f-ee6679d073a9'}
{endregion}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)