using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\B#\s?)((\S+\s+\S+\s+\S+)|(.*?#))";
string input = @"#test1 test2 #test3 test4 test5 #test6 test7 test8 test9 test10#test11 test12 #test13 test14 test15 test16 test17";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}