re = /(?:\B#\s?)((\S+\s+\S+\s+\S+)|(.*?#))/i
str = '#test1 test2 #test3 test4 test5 #test6 test7 test8 test9 test10#test11 test12 #test13 test14 test15 test16 test17'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end