import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@\\(\n"
+ " (?:\n"
+ " \\s*\n"
+ " (?:\n"
+ " \"[^\"\\\\]*(?:\\\\.[^\"\\\\]*)*\"\n"
+ " |\n"
+ " [\\w-]+(?:=\"?[^\"\\\\]*(?:\\\\.[^\"\\\\]*)*\"?)?\n"
+ " )\n"
+ " )+\n"
+ " \\s*\n"
+ "\\)";
final String string = "@(\"hello, world\" bold italic font-size=\"15\")";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}