$re = '/(?:
"([^"\\\\]*(?:\\\\.[^"\\\\]*)*)"
|
[\w-]+(?:="?[^"\\\\]*(?:\\\\.[^"\\\\]*)*"?)?
)
/x';
$str = '@("hello, world" bold italic font-size="15")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);