#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\\caption{((?:[^\\{}]|\\.)*)}"
Local $sString = "%ORIGINAL" & @CRLF & _
"\caption{ Some \{ \}text" & @CRLF & _
"some other text }" & @CRLF & _
"%..." & @CRLF & _
"\env2{ \caption{ Other text } }"
Local $sSubst = "\\caption{\\scriptsize\\textbf{$1}}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)