const regex = /\\caption{((?:[^\\{}]|\\.)*)}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\caption{((?:[^\\\\{}]|\\\\.)*)}', 'g')
const str = `%ORIGINAL
\\caption{ Some \\{ \\}text
some other text }
%...
\\env2{ \\caption{ Other text } }`;
const subst = `\\caption{\\scriptsize\\textbf{$1}}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);