re = /\\caption{((?:[^\\{}]|\\.)*)}/
str = '%ORIGINAL
\\caption{ Some \\{ \\}text
some other text }
%...
\\env2{ \\caption{ Other text } }'
subst = '\\\\caption{\\\\scriptsize\\\\textbf{$1}}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result