const regex = new RegExp('([|][-])(\\s)(Feature)(\\s)(name)(\\s+)[:](\\s+)["\\'](\\s)(SLM_Pool)(\\)s["\\'](\\s+)([|][-])(\\s)(Feature)(\\s)(version)(\\s+)[:](\\s+)["\\']["\\'](\\s+)([|][-])(\\s)(License)(\\s)(type)(\\s+)[:](\\s+)["\\']((\\w|\\|\\.|\\-|\\s)+)["\\'](\\s+)([|][-])(\\s)(License)(\\s)(Version)(\\s+)[:](\\s+)((\\w|\\|\\.|\\-|\\s)+)(\\s+)([|][-])(\\s)(Commuter)(\\s)(license)(\\s)(allowed)(\\s+)[:](\\s+)((\\w|\\|\\.|\\-|\\s)+)(\\s+)([|][-])(\\s)(Maximum)(\\s)(commuter)(\\s)(checkout)(\\s)(days)(\\s+)[:](\\s+)((\\w|\\|\\.|\\-|\\s)+)(\\s+)([|][-])(\\s)(Maximum)(\\s)(concurrent)(\\s)(user)\\(([^\\)]+)\\)(\\s+)[:](\\s+)((\\w|\\|\\.|\\-|\\s)+)(\\s+)([|][-])(\\s)(Unreserved)(\\s)(tokens)(\\s)(in)(\\s)(use)(\\s+)[:](\\s+)((\\w|\\|\\.|\\-|\\s)+)(\\s+)([|][-])(\\s)(Commuter)(\\s)(tokens)(\\s)(in)(\\s)(use)(\\s+)[:](\\s+)((\\w|\\|\\.|\\-|\\s)+)(\\s+)([|][-])(\\s)(Commuter)(\\s)(tokens)(\\s)(left)(\\s+)[:](\\s+)((\\w|\\|\\.|\\-|\\s)+)(\\s+)([|][-])(\\s)(Reserved)(\\s)(tokens)(\\s)(in)(\\s)(use)(\\s+)[:](\\s+)((\\w|\\|\\.|\\-|\\s)+)', 'gmi')
const str = `@F0GGY945
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}