$re = '/the (?>big|small|biggest) (cat|dog|bird)/m';
$str = 'the big dog
the small bird
the biggest dog
the small cat';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);