$re = '/\{\\\\fsp-?((\d+)|(\d+\.\d+))\}/m';
$str = 'This pattern must match fsp tag with different values like {\\fsp-0.667} or {\\fsp-4} or {\\fsp1.333}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);