using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^if\s*\((.+)\)\s((?:(?!else|endif).)+)(?:\selse\s((?:(?!endif).)+))?\sendif$";
string input = @"if(stat(life) >= 2) abc(5) deal_damage(5) else gain_block(5) endif
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}