#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)BBB((?:B(?:B(?:[^B])|[^B])|[^B])*?)EEE"
Local $sString = "BBB foo BBB bar EEE" & @CRLF & _
"" & @CRLF & _
" BBB bar EEE baz EEE" & @CRLF & _
"" & @CRLF & _
"BBB foo BBB bar EEE baz EEE" & @CRLF & _
"" & @CRLF & _
"BBBB EEEE" & @CRLF & _
"BBBBB EEEE" & @CRLF & _
"BBBBBB EEEE" & @CRLF & _
"BBBB EEEEE" & @CRLF & _
"BBBBB EEEEE" & @CRLF & _
"BBBBBB EEEEE" & @CRLF & _
"BBBB EEEEEE" & @CRLF & _
"BBBBB EEEEEE" & @CRLF & _
"BBBBBB EEEEEE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")