Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
BBB((?:(?!BBB).)*?)EEE
/
gm
Input 1
1
New
BBB foo BBB bar EEE BBB bar EEE baz EEE BBB foo BBB bar EEE baz EEE BBBB EEEE BBBBB EEEE BBBBBB EEEE BBBB EEEEE BBBBB EEEEE BBBBBB EEEEE BBBB EEEEEE BBBBB EEEEEE BBBBBB EEEEEE