# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?s:START.*?END)|\/\/.*|\.\s*\w+\b)(*SKIP)(*F)|old"
test_str = ("__DATA__\n"
"xx START xx old xx END xx --> ignore\n"
"xx old xx --> REPLACE !\n"
"START xx old --> ignore\n"
" xx old xx END --> ignore\n"
" xx old xx --> REPLACE !\n"
"// xx old --> ignore\n"
"xx // xx old --> ignore\n"
"xx . old old xx --> ignore first one, replace second one\n"
".\n"
" old --> ignore\n"
" (old) xx --> REPLACE !\n"
"xx old xx --> REPLACE !")
subst = "new"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.