import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-z]+([\\n].*?<\\/div>[\\n ]+<div class=\"large-3 small-3 columns\">[\\n ]+)[a-z]+";
final String string = "\n"
+ "<div class=\"row\">\n"
+ " <div class=\"large-3 columns displayoffer-centered\">\n"
+ " <small>1 ⨯ <img src=\"/static/currency/Exalted_Orb.png\" class=\"currencyimg\"> ← 1500 ⨯ <img src=\"/static/currency/Orb_of_Alteration.png\" class=\"currencyimg\"></small>\n"
+ " </div>\n"
+ " <div class=\"large-6 columns\">\n"
+ " <div class=\"displayoffer-primary displayoffer-centered\">\n"
+ " <div class=\"row\">\n"
+ " <div class=\"large-3 small-3 columns\">\n"
+ " exalted\n"
+ " </div>\n"
+ " <div class=\"large-6 small-6 columns displayoffer-text\">\n"
+ " <div class=\"displayoffer-left\"><img src=\"/static/currency/Exalted_Orb.png\" class=\"currencyimg\"></div>\n"
+ " <div class=\"displayoffer-right\"><img src=\"/static/currency/Orb_of_Alteration.png\" class=\"currencyimg\"></div>\n"
+ " <div class=\"displayoffer-middle\">1 ⇐ 1500</div>\n"
+ " </div>\n"
+ " <div class=\"large-3 small-3 columns\">\n"
+ " alteration\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n"
+ " <div class=\"large-3 columns displayoffer-centered\">\n"
+ " <small>1 ⨯ <img src=\"/static/currency/Orb_of_Alteration.png\" class=\"currencyimg\"> → 0.0007 ⨯ <img src=\"/static/currency/Exalted_Orb.png\" class=\"currencyimg\"></small>\n"
+ " </div>\n"
+ "</div>\n"
+ "<div class=\"row\">\n"
+ " <div class=\"large-12 columns\">\n"
+ " <div class=\"displayoffer-bottom\">IGN: MoreSpellDamage <span class=\"right\"><a href=\"#\" onclick=\"contact_form(this); return false;\">Contact seller</a></span></div>\n"
+ " </div>\n"
+ "</div>\n"
+ "</div>\n\n"
+ " <div class=\"displayoffer\" data-username=\"joshxx\" data-sellcurrency=\"6\" data-sellvalue=\"1.0\" data-buycurrency=\"7\" data-buyvalue=\"1650.0\" data-ign=\"joshhhz\">\n"
+ "<div class=\"row\">\n"
+ " <div class=\"large-3 columns displayoffer-centered\">\n"
+ " <small>1 ⨯ <img src=\"/static/currency/Exalted_Orb.png\" class=\"currencyimg\"> ← 1650 ⨯ <img src=\"/static/currency/Chromatic_Orb.png\" class=\"currencyimg\"></small>\n"
+ " </div>\n"
+ " <div class=\"large-6 columns\">\n"
+ " <div class=\"displayoffer-primary displayoffer-centered\">\n"
+ " <div class=\"row\">\n"
+ " <div class=\"large-3 small-3 columns\">\n"
+ " exalted\n"
+ " </div>\n"
+ " <div class=\"large-6 small-6 columns displayoffer-text\">\n"
+ " <div class=\"displayoffer-left\"><img src=\"/static/currency/Exalted_Orb.png\" class=\"currencyimg\"></div>\n"
+ " <div class=\"displayoffer-right\"><img src=\"/static/currency/Chromatic_Orb.png\" class=\"currencyimg\"></div>\n"
+ " <div class=\"displayoffer-middle\">1 ⇐ 1650</div>\n"
+ " </div>\n"
+ " <div class=\"large-3 small-3 columns\">\n"
+ " chrome\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n"
+ " <div class=\"large-3 columns displayoffer-centered\">\n"
+ " <small>1 ⨯ <img src=\"/static/currency/Chromatic_Orb.png\" class=\"currencyimg\"> → 0.0006 ⨯ <img src=\"/static/currency/Exalted_Orb.png\" class=\"currencyimg\"></small>\n"
+ " </div>\n"
+ "</div>\n"
+ "<div class=\"row\">\n"
+ " <div class=\"large-12 columns\">\n"
+ " <div class=\"displayoffer-bottom\"><span class=\"success label\">online</span> · IGN: joshhhz <span class=\"right\"><a href=\"#\" onclick=\"contact_form(this); return false;\">Contact seller</a></span></div>\n"
+ " </div>\n"
+ "</div>\n"
+ "</div>\n\n"
+ " <div class=\"displayoffer\" data-username=\"deadlylegolas\" data-sellcurrency=\"6\" data-sellvalue=\"1.0\" data-buycurrency=\"7\" data-buyvalue=\"1700.0\" data-ign=\"LegoSaiyanGod\">\n"
+ "<div class=\"row\">\n"
+ " <div class=\"large-3 columns displayoffer-centered\">\n"
+ " <small>1 ⨯ <img src=\"/static/currency/Exalted_Orb.png\" class=\"currencyimg\"> ← 1700 ⨯ <img src=\"/static/currency/Chromatic_Orb.png\" class=\"currencyimg\"></small>\n"
+ " </div>\n"
+ " <div class=\"large-6 columns\">\n"
+ " <div class=\"displayoffer-primary displayoffer-centered\">\n"
+ " <div class=\"row\">\n"
+ " <div class=\"large-3 small-3 columns\">\n"
+ " exalted\n"
+ " </div>\n"
+ " <div class=\"large-6 small-6 columns displayoffer-text\">\n"
+ " <div class=\"displayoffer-left\"><img src=\"/static/currency/Exalted_Orb.png\" class=\"currencyimg\"></div>\n"
+ " <div class=\"displayoffer-right\"><img src=\"/static/currency/Chromatic_Orb.png\" class=\"currencyimg\"></div>\n"
+ " <div class=\"displayoffer-middle\">1 ⇐ 1700</div>\n"
+ " </div>\n"
+ " <div class=\"large-3 small-3 columns\">\n"
+ " chrome\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n"
+ " <div class=\"large-3 columns displayoffer-centered\">\n"
+ " <small>1 ⨯ <img src=\"/static/currency/Chromatic_Orb.png\" class=\"currencyimg\"> → 0.0006 ⨯ <img src=\"/static/currency/Exalted_Orb.png\" class=\"currencyimg\"></small>\n"
+ " </div>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}