const regex = new RegExp('\\sUsername\\s\\'(?<username>[^\\']+)\\'.*\\n.*\\(/(?<ipaddress>[^\\)]+)\\).*Failed\\sto\\sverify\\susername', 'gmi')
const str = `[18:56:57] [User Authenticator #2/INFO]: Disconnecting *** (/185.204.1.184:58084): Failed to verify username!
[18:56:57] [User Authenticator #2/ERROR]: Username '***' tried to join with an invalid session
[18:56:57] [Server thread/INFO]: *** (/185.204.1.184:58084) lost connection: Failed to verify username!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}