re = /(\w+|[-.;?!,:])/ix
str = 'However, I now have words like these:
Word-another-word
more_words_like_these
and I would like to be able to retain the integrity of these words as they are (connected) but my current preg_match breaks them down into individual words.'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result