import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/.*\\/(?!.*\\/.+))";
final String string = "site.com/foo/remove-me/\n"
+ "site.com/user/account/info/settings\n"
+ "site.com/foo/bar/remove-me\n"
+ "site.com/foo/remove-me?param1=true¶m2=hello+world\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}