#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(https?:\/\/)?(v|player)\.youku\.com\/(v_show|player\.php|embed)(\/sid)?\/(id_)?(\w+)|(\w+)"
Local $sString = "http://v.youku.com/v_show/id_XMTMwMDYxMjQxMg==_ev_1.html?from=y1.3-idx-uhome-1519-20887.205805-205902.1-1" & @CRLF & _
"http://v.youku.com/v_show/id_XMjMxOTQyOTQw.html?from=y1.6-97.3.1.a44aa406e0c711df97c0" & @CRLF & _
"http://v.youku.com/v_show/id_XMTI5Mjg5NjE4MA==.html?from=y1.3-idx-uhome-1519-20887.205921-205922-205810-205923.1-1" & @CRLF & _
"http://v.youku.com/v_show/id_XMTI5Mjg5NjE4MA==.html" & @CRLF & _
"http://player.youku.com/player.php/sid/XMTI5Mjg5NjE4MA==/v.swf" & @CRLF & _
"http://player.youku.com/player.php/sid/XMTI5Mjg5NjE4MA==/v.swf" & @CRLF & _
"http://player.youku.com/embed/XMTI5Mjg5NjE4MA=="
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")